Jump to content

Problem with the Taloc's campaign

Recommended Posts

Okay, First I have never had such a problem with Support. O.o

I have levelled up a character that is about to do the campaign in Taloc; "Help in the Hollow". I talked to Lothas and I entered the Taloc, did all that was required and when I finished Lothas was not giving me the quest done but he was asking me to do it again.  So thinking I may have done something wrong I did it again the next day. Guess what? :) After my completion of "Help in the Hollow" same thing happened Lothas was asking me to do it like I did not!

I sent a ticket to Support and after many messages, I gave it up, they were saying to do it, not understanding that I did already twice. They told me to do repair and sent me how to do it; which I did. Tried again to do Taloc after repair and nothing changed, practically I have done this quest/campaign so many time that I do not get lost anymore. From my last message to Support I tried to explain my problem the best I could........(I do not wish to do Taloc anymore...grrr) but they said:  "I reviewed this case and a Taloc's Hollow Bonus Entry Scroll has been added to your inventory so that you may run the instance again").  That made me laugh! Because you do not need a scroll to enter Taloc you just wait the time and you are in, plus again they do not understand

I think the problem is to who respond to the messages, I had all different people to write a response to my inquiries.!

Now I know that most of you do not do Taloc because you all are high levels but I would like to be able to do "all" campaigns in Aion but it seems I'm stuck.

Sorry I needed to rant about this since after wasting so much time, in the end, I did get nothing. Sigh. :(


Link to post
Share on other sites

well. Was a long time since my last Taloc, but lets see if we can find the answer.

First at all I remeber that the quest and some missions were in some way complicated. You need to do a lot of quest before being able to enter (porb not your issue) and some of the items to collect there were hard to see. 

Not sure if the main quest requested to kill all the minibosses in the instance first or was ok with just the last one. But if my memory does not fail, the last boss is supposed to drop an item after you kill it. That item can be the answer you need. (please somebody else correct me if I am wrong). Some bosses still drop quest items even if your level is too high for them, but some do not. If after you kill the boss it just disapear and you can not loot it, maybe you are not completing the quest for that reasson. 

Try to check what the quest say and if it requires something. 

another option could be if the quest requires to kill every single boss there, there is an spider that sometimes does not appear. That boss was at the end of the S shaped way. 

Link to post
Share on other sites

:) Azzmaria first thank you for trying to help me. <3

What you said I did all. I have done Taloc killing all bosses, all insects and got the knobs too, went even into the cave and of course killed the last boss, which only drops some items like a hat, armour pieces and other stuff. I did the Taloc also with some of my other characters not in the same account with the same result so I thought there was something wrong, perhaps a bug and I contacted Support. It seems that there is nothing I can do to complete it. 

I even did a repair under the instruction of someone in the Support but nothing has changed. In Taloc there are no more quests given to me to do besides the campaign "Help in the Hollow" which at the moment I'm not very happy to do again for the fifth time. :)

Link to post
Share on other sites

@KallSu - :) I know how to do this campaign, I am playing Aion since 2009 and I have several accounts. I do not like PvP and for that, I'm levelling up several of my alts that I was keeping as keeper of my many items. So I did Taloc many, many times and I never had this problem.

Lothas does not ask you to do 20 times something, I know what you are talking but that is part of another quest not the campaign.


I will have to let Taloc go even if I would like to complete all campaign in Ingisson. :)

I know that not many players are doing these low-level campaigns but with my level 70 and over I get killed in Illuma so very often that I do not enjoy playing my character plus "all" my friends have left the game, my legion is empty and I have nobody to play with..... I love Aion and it's hard for me to leave, perhaps sooner or later I will have. :(

Edited by Melodiosa-KT
Link to post
Share on other sites

The 20 times red orb is the campaign quest. I know that for sure. The other three orbs are a blue quest.

Also, it's been a while since I've done it, but I thought you turned it in to Taloc inside the instance after beating fatbad mob.



Pull up Aion Codex and look up Help in the Hollow. It tells you what to do.

Edited by Cheesecake-DN
Link to post
Share on other sites

This has happened to me before. It took me 4 tries to do the campaign quest, and I know I was doing it right. The quest just wouldn't update until it finally did the 4th time -- and I hate Taloc's Hollow, so this was pure torture for me lol. It has never happened on any other toon though, before or after that glitchy toon.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...