Jump to content
UrimVAV-DN

Problem between NVIDIA Panel and Aion Laucher

Recommended Posts

Hi,
Recently, I bought a SSD and installed on my notebook. I, then, uninstalled Aion from my HD and downloaded the game, installing it on my SSD. When I got in the game, I found my FPS to be way lower than I expected. I started looking out for the problem I was having. I right clicked the Aion Launcher and I figured out it was using my Intel Graphics 630 GPU, not my GTX 1050 TI. I tryed changing it by right clicking Aion, choosing "Run with Graphics Processor" and then clicking on "Change Graphics Processor" (Currently, it`s choosen Integrated Graphics) . By doing this, NVIDIA Panel opens up, but it doesn`t show Aion, it shows "Netflix (4DF9E0F0.Netflix)". So, in other words, I'm guessing that NVIDIA Panel thinks Aion is a Netflix Application, which is why it`s not using my GTX 1050TI. Thing is I don`t even have Netflix on my notebook.
I tryed uninstalling game and installing it a few times. I already contacted NVIDIA support, but I don`t have an answer till now. I also performed a clean uninstall of my graphic drivers, but it didn't work either...
Before uninstalling and installing Aion, I used to play normally, with 50-70 FPS. So, my GPU used to work fine. Something happened after I reinstalled Aion.

https://imgur.com/SFPEsh2
Right clicked aion

https://imgur.com/CBVrdq1
Clicked on Run with Graphics Processor and the option Integrated Graphics is already selected

https://imgur.com/J8FVrUE
Clicked on Change Graphics Processor and it opens up as Netflix Application

 

Share this post


Link to post
Share on other sites

Internet search says go to bios and there should be an option for laptop to boot using the pci card. Or similar settings about the graphics card.

 

What laptop you have?

Share this post


Link to post
Share on other sites
15 minutes ago, UrimVAV-DN said:

I have a Dell Inspiron 7567.

Do you have any guideline I could follow when I get to BIOS?

I wish I did. If I was at home, I could look at my Dell and try to give you an idea by looking around myself. :(

 

I'll be home in about three hours, so if anyone breaks anything, it's me, lol. Just wait or Google around for other,nonbios solutions. 

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, UrimVAV-DN said:

Np, I can wait! Ty!

I haven't forgotten about you! I had a doc appointment I forgot about q_Q

Do you have access to another monitor?

The internet says to go to "In BIOS, Video settings, disable "Enable Switchable Graphics". After restart, it assumed only dedicated GPU."

 

Edit:

You can also try going to that Global Settings tab on the NVIDIA Control Panel and setting the Preferred graphics processor to your NVIDIA one. D:

Edited by Cheesecake-DN

Share this post


Link to post
Share on other sites

Thanks a lot fpr the help! I performed a clean uninstall of my graphic drivers and it's working out just fine. I'll try this for now. If I get another problem, I'll use this info you searched for me!

Ty very much!

Share this post


Link to post
Share on other sites
39 minutes ago, UrimVAV-DN said:

Thanks a lot fpr the help! I performed a clean uninstall of my graphic drivers and it's working out just fine. I'll try this for now. If I get another problem, I'll use this info you searched for me!

Ty very much!

Glad to hear you got it working! :>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×