Jump to content
SneakAttack-DN

Error 2009 (help me!!)

Recommended Posts

I am consistently getting this error and can not log into the game. I have tried some fixes that are on the forums, google, youtube etc and no luck...The support team is not being very helpful so I am reaching out to you all lovely people.

 

explorer_LOyfAxjrdY.png

Share this post


Link to post
Share on other sites

I do not use a anti-virus program and I turned windows defender off.

I was using Exit Lag at the time I had the issue ( I have tried uninstalling exit lag and running aion still error)

I am hardwired to the router and the router is connected to the modem provided by the ISP

I went into my router setting and opened the ports that I found on the NCSoft site, I used a restore point that predated this issue, I uninstalled the launcher and reinstalled, I tried running as administrator, I tried changing the DNS and refreshing, I am utterly lost. I am sure it is something simple that I am over looking and I would appreciate any help @Cheesecake-DN

Share this post


Link to post
Share on other sites
58 minutes ago, SneakAttack-DN said:

I do not use a anti-virus program and I turned windows defender off.

I was using Exit Lag at the time I had the issue ( I have tried uninstalling exit lag and running aion still error)

I am hardwired to the router and the router is connected to the modem provided by the ISP

I went into my router setting and opened the ports that I found on the NCSoft site, I used a restore point that predated this issue, I uninstalled the launcher and reinstalled, I tried running as administrator, I tried changing the DNS and refreshing, I am utterly lost. I am sure it is something simple that I am over looking and I would appreciate any help @Cheesecake-DN

Unfortunately, I don't think it's anything simple, and it might be something NCsoft side or got changed in the launcher. Legionmate is having the same problem, too, as is another person here on the forums. What region are you? Like West Coast USA or something.

 

I'll try brainstorming and googling some stuff. If things like flushdns and changing DNS and such isn't doing anything...

 

Share this post


Link to post
Share on other sites
Aly-DN   
8 hours ago, KonkersGG-EK said:

Try reinstalling NCWest Launcher. I'll send you the link on PM.

Edit:
Nevermind, here is the official link: http://launcher.patcher.ncsoft.com/NC-Launcher/NC-LauncherSetup.exe

Edit2:
I see that you have already tried this. Well... contact support then and ask them if your IP is blocked or something!

An IP ban wouldn't result in that error. He would be getting the message that he was banned.

Share this post


Link to post
Share on other sites
1 hour ago, Aly-DN said:

An IP ban wouldn't result in that error. He would be getting the message that he was banned.

No, not his account. His IP might have been blacklisted. IDK. It seems like a internet related issue.

Seems like an error I was getting a while back and it was related to the launcher only. Reinstalling the launcher as admin fixed it for me.

Try removing the launcher and reinstalling it as admin. The instalation itself, run it as admin.

Share this post


Link to post
Share on other sites
Gabe-DN   

I may be mistaken but it seems I had this problem one year when I took my laptop with me on vacation one year after I had just reformatted it and I spent a day or two reading mostly garbage posts but it I seem to remember right clicking on the icon and changing it to run in compatibility for windows 7 and it ended up working fine.  This was a couple years ago, I could be mistaken but it is worth trying.

Share this post


Link to post
Share on other sites

I used to get this error a lot when my WiFi takes a crap for ten minutes every so often...I have since started running in compatibility mode like @Gabe-DN suggested and this happens a LOT less to me now. I'd second trying compatibility mode, since if you have Windows 10 it tends to mess with the client in various ways for everyone.

Share this post


Link to post
Share on other sites

Have you tried the bin file trick? Changing aion.bin to aion.bin.old? Dunno if that will work with the error your getting but while I was on vacation for a month I used an older Windows 7 laptop to play and I had to do this every time the game patched or updated or I'd get error messages on login. I have since switched this laptop to Windows 10 configured to Run Aion in Windows 8 mode like my main gamer is and thus no longer have any problems with errors.

It's worth a try. Cheesy is better with software issues than I am. My specialties are hardware and coding. So I'd listen to her suggestions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×