Jump to content
Sign in to follow this  
LordGoldenChild-KT

Back to the game PING 990+ in Wa State

Recommended Posts

Posted (edited)

so just got my newer PC up and running...
Logged into the game...
Just clicking on my Pin was 4 second delays...
Got into the game...
and compleatly unplayable.. 
900+ ping most the time ?
any ideas ..?

Edited by LordGoldenChild-KT
spelling

Share this post


Link to post
Share on other sites

Have you tried using a trial version of battleping to see if that helps? Maybe something like ReduceTheLag? I don't know. There are probably a few other ping reducers to try. I haven't had ping problems for a while. It could be something on your end or between you and your internet's route to the Aion servers.

Share this post


Link to post
Share on other sites

ReduceTheLag will surely do and it has 30 days full version, free trial. I no longer need it to play, when 7.5 came the lag was unbearable, even people from USa would get a ton of lag spikes, it took them about 1 month to actually do something about it. But some people still lag.

Share this post


Link to post
Share on other sites

looked like it's a video card issue...  wold not load my drivers... 8 hours later don't know what i did right... but they loaded.
back in game getting 50fps.. it was about 2
Ping still about 90 though.
And get a black screen if i stay in high def in town for more than a few min.

 

Share this post


Link to post
Share on other sites
13 hours ago, LordGoldenChild-KT said:

And get a black screen if i stay in high def in town for more than a few min.

This happens to me sometimes and 99% of the time, it's because the drivers for my graphics card need to be updated. I know you said you fixed that, but you might check again just to be sure.

Share this post


Link to post
Share on other sites

90 ping is about right though maybe a little high the further away states get somewhere from 68-100ms depending where since server is TX I believe still. the rest ya check drivers and maybe double check if your graphics card is running right, with a benchmark or something so you aren't unknowingly overdoing it. I am staying in NC rn and I get 48-78ms and I just cap my fps at 60 so I don't have issues and I run the 2080 TI SLI for my current set up (I know is way overkill for aion and not needed but I play other games)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×