Jump to content
Forums

NC Launcher 2 not working - Unable to play Aion Classic


Recommended Posts

Aion support is telling me to take it up with my ISP.  My ISP is telling me this is out of the scope of their tech support. 

1. The ONLY connection/internet issue is with Aion, everything else works great.

2. I have turned off all VPN, Firewall, AV and even tried loading from Windows 10 Safe Mode.

3. I changed my network card to Private vs Public, per the ISP.

The Launcher just sits and spins endlessly or sometimes I will get the error  "Failed to read content data from the update server, Check network environment".  I was told to install and run WinMTR by Aion Support, which provides this info:

many packets transferred to various IP addresses, but one entry is:

No response from host -  100% packet loss

It seems this is the issue, maybe a authentication server ?  idk

I even rolled back the last Windows 10 security update, to no avail. This problem only started a couple days ago. It worked fine until something changed. I want to continue playing Aion Classic but sadly will be forced to leave due to not being able to log in...

Can anyone help? Please ?

Link to post
Share on other sites

While playing today Game started pausing and freezing, then NC launcher crashed , the same issue and I am sure my ISP is not the same one you use,

I called Range they checked it out and said all is fine on this end. 

Link to post
Share on other sites
  • 2 weeks later...
  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...