Jump to content
Forums

Recommended Posts

Hello everyone, i was hoping someone could help me or give me some kind of explanation why am i getting such crappy fps while playing this game.
I know i have potato pc, but i think i should be able to get more than 20fps..
I have Geforce gtx 560 1Gb(Geforce model) phenom ii x3 555(unlocked phenom ii x2 555, fourth core wasnt working good, so i disabled it) OCed to 3.5
And 4Gb DDr2 ram 1066mhz(I had 6Gb few days ago, but i removed 2gb thinking about getting 4Gb Stick)
WD 500Gb HDD

So funny thing is, afterburner and riva, are showing me that my gpu usage is never getting higher than 45%
And same goes with my cpu cores
Core 1 14-30% usgae
Core 2 same
Core 3 goes up to 70%
But in moments when im at Norsvold lets say, main city
Default Engine
Texture set on medium, the range to see players set to medium
water set to medium
shader set to medium
Bloom 2, everything else ultra low
Weather turned on, show effects for all and details for other players set to high
Anyway even thou im using shift f12 option my fps is still on 20 and i even get drops to 11fps
Gameplay is just choppy
Ive tried doing many things, turning everything off and to low settings, all it does it gives me extra 7-9fps
Fps is then 18-27
I dont understand how can a dx9 game have such hungry apettite for space pc
At the moment i cant afford to change my entire rig, but maybe i could get some intel i3 older cpu with intel mobo if that would increase my fps
But in general can someone help me

Link to post
Share on other sites

it's something in the base software that just poorly utilizes hardware, 1.x days a 2.5ghz dual core, any maker and a TNT2, of all things, use to run this game at 45-50 fps medium settings but no bloom. That's what I had back at launch and was able to jumpshot like crazy on like a 512k adsl connection(did it with a gladiator silly enough...), now with hardware that's maybe a year old and 60mb/s cable, I can't do it at all.

Edited by Kiatra-BR
Link to post
Share on other sites

I your potato pc is a laptop, check that you have the Power Save Mode in aion ( Options -> System Settings ) disabled. Check if it is a desktop too, could be that the problem.

Also check that in your windows power planning settings you have all on maximum performance.

Link to post
Share on other sites

Yeah, it is desktop pc, not laptop, i do have max.performance when im playing aion.
I menaged to somehow improve the fps in game.
Not by much, but in general flow of the game is somewhat better.
Ive disabled display scaling in Nvidia control panel, and in compatibility mode ckecked to run windows xp service pack 3 if someone else has issues, can try doing this, will improve the gameplay flow, not by much, but much better than, those "who modify config" Which for me doesnt work at all...

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...